LinkedIn's share feature sometimes displays the wrong image in a shared post. LinkedIn uses data from Facebook's Open Graph Protocol to display shared posts. If the correct image displays on Facebook, but the wrong image displays on LinkedIn, the issue most likely lies in LinkedIn's sharing tools. The steps in this article may help resolve the issue.
Note
For selecting images that work well with different social media platforms, see this article.
While we can suggest how to optimize your content for social media sharing, ultimately LexBlog has little control over issues with LinkedIn's software. If these steps do not work, we suggest contacting LinkedIn support.
LinkedIn displays the wrong image when you share a post
Cause
Your image does not meet Facebook's best practices guidelines.
Remedy
Upload an image:
- At least 1200 x 630 pixels.
- Up to 8 MB in size.
- "As close to 1.91:1 aspect ratio as possible."
Cause
There is another issue with the image you uploaded.
Remedy
Use Facebook's image sharing debugger tool. The tool will tell you if there are any technical issues with your image.
Use LinkedIn's post inspector tool to attempt to clear the image caching in LinkedIn's network.
You changed your image, but LinkedIn displays the old image
Cause
Someone already shared your post on LinkedIn, and LinkedIn is displaying the older image cached from their servers.
Remedy
Use LinkedIn's post inspector tool to attempt to clear the image caching in LinkedIn's network.
Force LinkedIn to scan the post again by appending ?1 to the original URL. Then share the new URL on LinkedIn. For example:
- Post URL on your site: https://www.yourblog.com/new-post
- New URL to share: https://www.yourblog.com/new-post?1