MailChimp employs a number of technologies to ensure high deliverability rates. When a reader does not receive a MailChimp campaign, there can be a number of causes. (If all readers at your own firm cannot receive campaigns, your IT team may need to address spoofing problems.) This article explains how to troubleshoot missed email notifications.
The campaign did not send after you published a post
Cause
Your scheduled send time is set for later in the day, or the post was published after the scheduled send time.
Remedy
- Check your campaign send time at Site Settings > Email Notifications. Check your email inbox after the scheduled send time. As MailChimp's servers send out millions of emails, campaigns may not reach your inbox for a few minutes after your scheduled send time.
- Make sure that all authors at your organization know when your campaigns are scheduled to send.
Cause
The post was published too close to your scheduled send time.
Remedy
- Check your campaign send time at Site Settings > Email Notifications. Publish posts at least 4 hours before your scheduled campaign send time.
- Make sure that all authors at your organization know when your campaigns are scheduled to send.
Cause
Your blog feed uses Feedburner and there was an error with the feed.
Remedy
Submit a request to switch your feed from Feedburner to XML. XML feeds are more reliable than Feedburner.
A reader did not receive a campaign
Cause
The reader is not subscribed to your list or has not confirmed their subscription.
Remedy
- Check your subscriber list for the reader's email address. If the email is not listed there, ask the reader to enter their email address in the blog's subscribe form and to confirm their subscription in the confirmation email.
- If you manage your MailChimp account, log in and check if the reader is listed as Pending Confirmation. If so, ask the reader to search their email messages for the subscription confirmation message with your site's title.
- If the reader has a user account on your site, you can subscribe them to the blog in their user profile.
Cause
The campaign was delivered to the subscriber's spam folder or another folder. For example, some Gmail subscribers may find the message in their Promotions or Social folder.
Remedy
Ask the subscriber to check their spam folder or other email folders.
Cause
The reader's email software or firewall has blocked emails from the sending IP address.
Remedy
- If you manage your own MailChimp account, check for any bounce reasons, or open a ticket with the Success Team to provide the bounce reason.
- The reader must ask their email provider or IT staff to review the bounce reply to take appropriate action.
- The IT staff can also whitelist MailChimp's delivery IPs if the security policy allows.
Cause
The campaign's send from address is not a trusted sender in your reader's email software.
Remedy
Ask the reader to add the "Send From" address to their email contacts, or whitelist the "Send From" email in their email software.
All subscribers at your firm did not receive a campaign
Cause
Your email software or IT staff have blocked emails from the sending IP address.
Remedy
- If you manage your own MailChimp account, check for any bounce reasons, or open a ticket with the Success Team to provide the bounce reason.
- Your IT staff can also whitelist MailChimp's delivery IPs if the security policy allows.
Cause
Your email campaign send from domain is identical to your firm's email domain (e.g., @yourlawfirm.com). Because your firm's email domain has no record of sending out the campaign, your email software blocks the campaign as a potential spoofing attack.
Remedy
Change the email campaign "Send From" address to notifications@lexblog.com. LexBlog has set up this alias to optimize email delivery.
See our Support article, About email spoofing issues, for additional troubleshooting suggestions.
Cause
The campaign was delivered to the reader's spam folder or other folders. For example, some Gmail subscribers may find the message in their Promotions or Social folder.
Remedy
Ask the reader to check their spam folder or other email folders, and to add the email "Send From" address to their email contacts.
Cause
The reader's email software or IT staff has blocked emails from the sending IP address.
Remedy
- If you manage your own MailChimp account, check for any bounce reasons, or open a ticket with the Success Team to provide the bounce reason.
- The reader must ask their email provider or IT staff to troubleshoot the issue using the bounce reason.
- The IT staff can also whitelist MailChimp's delivery IPs if the security policy allows.